Respaldos de SQL Server 2008 en unidades de red

En nuestro ambiente de desarrollo tenemos una infraestructura montada en servidores virtuales, utilizando Hyper-V, en una de las máquina tenemos instalado Windows Server 2008 R2 y SQL Server 2008 R2 Edición Estandar,
dentro de este servidor de base de datos tenemos varias instancias creadas, las cuales tenemos que respaldar, lo que decidimos hacer es mandar estos respaldos al servidor host, por medio de una unidad de red.

El problema que se nos presento fueron básicamente dos:
1.- Al momento de crear el plan de mantenimiento, no reconocía la unidad de red que tenemos conectada.
2.- Si poníamos directamente la URL de la carpeta nos daba el siguiente error:

Mens. 22048, Nivel 16, Estado 1, Línea 0
xp_create_subdir() devolvió el error 5, ‘Acceso denegado.’

Buscando una solución a este problema encontré en Idea Manglar, la solución la cual consiste en lo siguiente:

Crear el siguiente script:

EXEC sp_configure 'show advanced options', 1
GO
RECONFIGURE
GO
EXEC sp_configure 'xp_cmdshell', 1
GO
RECONFIGURE
GO
EXEC xp_cmdshell 'net use [UNIDAD_LIBRE]: \\[SERVIDOR]\[DIRECTORIO_COMPARTIDO] [CONTRASEÑA] /user:[DOMINIO\USUARIO]'

Esto nos genera la conexión a la unidad de red, pero hay que aclarar que solo la va a reconocer el SQL Server 2008 no así el explorador de Windows.

Adicionalmente ya teníamos configurada la parte de:

  • Correo electronico (Management/Database Mail)
  • Creado el operador (SQL Server Agent/Operators)
  • Creado el plan de mantenimiento (Management/Maintenance Plans)Este último es el que nos va a permitir:
  • Verificar la integridad de la base de datos.
  • Reorganizar los índices.
  • Actualizar las estadisticas.
  • Realizar respaldos totales y/o incrementales.
  • Enviar un correo electrónico con el informe del plan.
  •  

    Fuente: Idea Manglar

    About these ads

    Un pensamiento en “Respaldos de SQL Server 2008 en unidades de red

    1. hola amigo, gracias por el post, muy util, solo tengo una duda, hice este procedimiento y todo bien, solo que cuando reinicias el server pierde la unidad de nuevo, no sé si ya lo habías visto, se tiene que dar de alta la ruta de nuevo, te pasa lo mismo?
      me gustaría saber si hay forma de dejarla fija

      gracias

      Carlos García

    Deja un comentario

    Introduce tus datos o haz clic en un icono para iniciar sesión:

    Logo de WordPress.com

    Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión / Cambiar )

    Imagen de Twitter

    Estás comentando usando tu cuenta de Twitter. Cerrar sesión / Cambiar )

    Foto de Facebook

    Estás comentando usando tu cuenta de Facebook. Cerrar sesión / Cambiar )

    Google+ photo

    Estás comentando usando tu cuenta de Google+. Cerrar sesión / Cambiar )

    Conectando a %s